Clicking the "Agents" button should lead to the Agents page instead of Clusters

Hi! First of all, thanks for your work on Buildkite.

In one of your latest updates, there has been a UI change which makes my use of buildkite slightly harder. When I click the “Agents” button in the header, now it leads to myOrgName/clusters instead of myOrgName/agents.

All of my agents are unclustured (I do not use the clusters feature), so if I want to quickly check which agents are free and which ones are busy, now I have to do two clicks. First, on the Agents button which leads me to the clusters page. Then, another click to the unclustered agents, to see them.

I hope the UI is improved so seeing available/busy agents is easier.

Hello, @ibrar! Welcome back to the Community!

Thank you for your feedback! Since clusters became generally available, unclustered agents being displayed in Unclustered agents in the UI is the expected behavior. Are you able to share any reasons why you are not using clusters?

You can reduce the number of clicks by using the following URL to get through to your unclustered agents directly:

In the future, I recommend giving clusters a go as with using clusters you’ll see no drastic changes in your overall Buildkite experience but you’ll gain more useful tools at your disposal like cluster queue metrics.


Hey! I’m not yet familiar with clusters, but I would probably just put all my agents in the same cluster. Thus I would end up having to make two clicks anyway.

Ideally, when you click Agents, it should give you agents, not clusters. Maybe pick a “default cluster” and open its agents? And those who want to see a different cluster they can make the second click (same number as currently).

I know it sounds stupid, but the number of clicks is really important to quickly see things for me, and probably other users.


1 Like

Thank you so much for explaining your potential usage scenario for clusters and for your feedback regarding the current UI, @ibrar. I’ve shared it with the team.


Hi @ibrar ,

I am from the product team at Buildkite. If you move all of your agents to a single cluster as you suggested, we can run a script to disable the unclustered view for you that will load the queues for you by default after which you can go to the relevant queue and inspect the agents.

Let me know if that would solve the problem for you. If yes please send us an email through so that we can help you out.

Have a great day!

Hey all - I’d like to second this. Our usage of buildkite predated clusters, and instead of moving everything into the “default” cluster, our agents were put into “unclustered” and a default cluster and queue was created for us. The transition isn’t great. Is there a way to batch update everything to the default cluster or do we need to manually update all our pipelines, queues and clusters to work with clusters?

1 Like

Hello, @donal!

Thank you for your feedback regarding the Cluster view and the new default behavior for agents and clusters. Sorry that the transition was not a completely smooth ride for you so far.

To update your pipelines to use the cluster(s) of your choice, you can use the following GraphQL query:

mutation UpdatePipelineCluster {
    input: {
      id: "{your-pipeline-GraphQL-id}"
      clusterId: "GraphQL-ID-of-the-cluster-you-want-to-set-for-the-pipeline"
  ) {
    pipeline {
      cluster {