Does the buildkite/agent-stack-k8s work with Buildkite Clusters feature?

I tried to set it up for the cluster but the agent always returns Failed to acquire job: PUT … 404

kubectl logs buildkite-... -n bk -c agent
2023-03-28 22:25:39 WARN   buildkite-... PUT 404 Could not find job: ... (Attempt 10/10) 
2023-03-28 22:25:39 INFO   buildkite-... Disconnecting... 
2023-03-28 22:25:40 INFO   buildkite-... Disconnected 
2023-03-28 22:25:40 FATAL  Failed to acquire job: PUT 404 Could not find job: ...

Hello @wallyqs! Thanks for reaching out to us :wave:

For the K8s Agent Stack, have you set its tags to target the same one as your setup Cluster upon installation? Im assuming you installed it via Helm, but please let me know if not.


Thanks James, yes I did an install via helm and did not set any tags (assumed it would be using the queue=kubernetes tag). The same setup outside in the cluster setup did work on the first try, but could not do the same when running with the cluster token.

No worries @wallyqs!

You are right that the queue=kubernetes is defaulted :+1:

I similarly ran a unclustered stack fine on my side locally - that being said I’ve got attention on this with our Engineering folks behind the K8s stack to see what the case is.

Cheers again and thanks for the quick feedback on this!

You are right that the queue=kubernetes is defaulted

Hi @wallyqs,

I’m an Engineer working on the agent. Thanks for pointing this out, it looks like a bug and I’ve been able to reproduce it. I’ll update you when we have a fix.



1 Like

Hi @wallyqs, I’ve released v0.5.1 that should allow you to run the stack for a pipeline in a cluster. Let us know how it works for you.

Thanks, confirmed it works now!