Git changes not pushing to AWS production env?

We recently updated from Rails 5.2 → Rails and ruby 2.5.2 → 2.7.0.
All tests and local environment are working as expected.
Changes pushed to Github are being picked up by Buildkite and tests are passing in Buildkite.
Buildkite is connecting to and starting the AWS production environment, spinning up and terminating the auto-scaling instance.
Deploy to production passes and there are obvious errors in buildkite log and everything looks normal in AWS (nothing pending etc).

However, when we log in to the production app, the changes we can see in local (and GitHub code) are not appearing in the app. I’m a bit lost!

Hi @scafflecollab thanks for reaching out :wave:

Have you confirmed the git commit being run in Buildkite is the same as the one you expect? And has this worked previously? Or is it a new workflow you are implementing?

I’m afraid the issue could be on the ruby/rails side but we’ll try to help out. Can you share a build URL with us? You can send it to if you want to keep it private.

Thanks! The CI process has been working (2018-2022), but we haven’t pushed anything to production since Sept 2022. When we last tried to push (Feb), there were broken packages which prompted the update to ruby/rails. The build url is - I can email more details if it’s helpful.
The git commit in Buildkite is the one I am expecting and the push from github is prompting test to run as expected.
I am getting a ‘deprecated environment variables warning’ for BUILDKITE_PROJECT_SLUG= & BUILDKITE_PROJECT_PROVIDER but I can’t find how to edit these.

BUILDKITE_REPO is there and correct though. I had to update my local ssh/knownhosts for the github RSA change - but that change didn’t seem to be effecting Buildkite receiving the github data.

Hello, @scafflecollab! Yes, please email the build URL and any additional details that you think might be helpful for us to troubleshoot the issue to, and we’ll look into it.